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How to Use This Guide
Welcome to the CoffeeCup Direct FTP Quick-Start Guide! This is the place to go to learn the ins and
outs of this program.
You can navigate through this guide using the table of contents in the PDF reader interface or by just
reading it straight through. You can also jump around using links, which are formatted in light blue
text.
You’ll see links to webpages containing additional information formatted like this: http://www.coffeecup.com/. Just click them, and your default web browser will open the page.
You’ll also notice that the guide is divided into different sections. If you want to learn how to perform
a task in the program, check out the Direct FTP Quickstart Guide section. It walks you through common tasks using simple, step-by-step instructions. Have a question? Visit the Frequently Asked Questions section. We’ve kept track of the questions we hear most often from our users and gathered them
together in this section.
We hope this helps! If you have any questions, comments, or suggestions about how this guide can be
improved, we’d love to hear them. Shoot us an e-mail at wordnerd@coffeecup.com. Any technical support requests should still go to http://www.coffeecup.com/help/myroom/.
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About this software
System Requirements
To run the software efficiently, your computer and server systems should meet the following requirements:
• Operating System: Windows XP, Windows Vista, Windows 7
• Disk Space: 30MB free disk space available
• RAM: 128MB (256 recommended)

Installing the Software
If you are installing the registered version of the software, it is highly recommended that you first
uninstall the trial version.
If you haven’t already downloaded your software, you can do so in your CoffeeCup user account
(http://www.coffeecup.com/login/). Once you have downloaded the software, double-click the .exe file
to start the setup process. As you proceed through the setup, you can let the program install with the
default settings, or you can choose where you would like it installed. We recommend you stick with
the default settings. Installing CoffeeCup software in the C: drive is recommended to avoid potential
errors.
Some parts of the installation process may be slow. Please be patient and wait for the installer to
completely finish in order to avoid an unsuccessful installation.

Upgrading the Software
When upgrading your software, you will need to log into your CoffeeCup user account (http://www.
coffeecup.com/login/) just as you did to download the registered version of the software. When you
download the upgrade, it will be a new full version and not just an upgrade to the existing software on
your system.

Uninstalling the Software
To uninstall, you will need to use the Add/Remove Programs feature under the control panel settings
in Windows. You can find this by clicking Start > Settings > Control Panel > Add or Remove Programs.
This process may not remove all related files from your system. You may need to remove some files and folders
manually. Also, if you have previously created projects, make sure to back them up to prevent loss.
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Getting to know the Direct FTP workspace
Here’s a quick overview of the major features of the Direct FTP workspace:

1. Local Pane

4. Editor Pane

Access files on your local computer.

Edit Webpage files, including HTML, CSS, text,
JavaScript, and more.

2. Remote Pane
Access files from your server.

5. Image Pane

3. Drag and Drop

Preview images and edit image HTML.

To transfer files from your computer to your server
or vice versa, just drag and drop them.

Direct FTP Quick Start Guide
Just a note before we get started: There are many different ways you can perform the functions we’ll
explain in this tutorial. For example, to open the transfers window, you can:
• Click the bottom right panel of the Direct FTP window
• Press Ctrl+T
• Go to View > Transfers Activity Window
All right, let’s get started!

Step 1: Setting up a Server Profile
The first thing you’ll have to do to use Direct FTP is set up a server profile. To do this, click the Servers
button in the Toolbar.

This opens the My Servers window, which allows you to set up either an S-Drive profile using your
CoffeeCup account information or a server profile by entering the information given to you by your
hosting provider when you signed up for web hosting. Here’s how to set up your S-Drive profile:

Click the S-Drive icon (it looks like a gear shifter) to create a new profile. Give this profile a unique
nickname, which can be any name you want to remember it by.
Enter your CoffeeCup username and password in the corresponding boxes. That’s all there is to it! You
can now upload files to your S-Drive account.
Don’t have an S-Drive account yet? Signing up is free! You can get your own S-Drive account by visiting
http://www.coffeecup.com/sdrive.
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Now let’s talk about how to set up an FTP server profile. If you are unsure of any of this information,
contact your hosting provider. Here’s what you put in each field:

1) Nickname. A nickname for the server profile being created. Since it’s just a personal reminder of
which server you’re using, you can name it anything you want.
2) Server. The location where you will upload your website’s files. It should be in the form of an IP
address, your domain name (e.g. yourdomain.com), or your domain name preceded by ftp. (e.g. ftp.
yourdomain.com). Do not include ftp:// or http://. It is up to your web hosting company to assign your
FTP server host name, so you will need to find out from them what it is.
Examples of valid server names
ftp.mysite.com			

24.24.100.100			

mysite.com

Examples of invalid server names
ftp://ftp.mysite.com		

http://www.mysite.com

3) Username. The FTP username assigned to you by your web hosting company. Be sure to enter the
information exactly how it was given to you by your provider. Usernames are case sensitive, so if there
are capital letters in your username, you must enter it that way.
4) Password. The FTP password assigned to you by your web hosting company. Be sure to enter the
information exactly how it was given to you by your provider. Passwords are case sensitive, so if there
are capital letters in your password, you must enter it that way.
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5) Show Password. Checking this box shows your password. Leaving it unchecked hides your password
as you type it.
6) Remember Password. Checking this box saves your password so you don’t need to type it in every
time you upload your files to your server.
7) Passive Mode. Checking this box activates passive mode. Passive mode is almost always needed
when you are connected to the Internet with an ADSL or Cable modem. If you are unsure, check this
option and use the “auto detect Passive mode” feature.
8) Add Server. To add a new server profile, click the green plus sign icon.
9) Delete Server. To delete a server profile, click the red minus sign icon.
10) More Options. Clicking this button allows you to work with more advanced FTP options.
11) Protocol. Specify your FTP connection. FTP and SFTP over SSH are the most commonly used protocols, but you can use FTPS over TSL/SSL, FTPS over SSL, FTPS over TSL, HTTP, HTTPS, or even CoffeeCup S-Drive.
12) Port. This option depends on what protocol you are using to connect to your FTP server. When you
select a protocol, the program automatically changes to the default port for you.
13) Connections. The number of simultaneous transfers allowed by the program. Generally, the lower
the number of connections, the more stable the transfers will be. We recommend keeping this number 1-2 lower than the maximum number of simultaneous connections allowed by your web hosting
provider.
14) Local Folder. The folder on your computer that you want to open in the Local pane by default.
15) Remote Folder. The folder on your server that you want to open in the Remote pane by default.
We recommend entering the root folder in this field. Common root folder names include www, public_html, or web. If you aren’t sure of this information, contact your hosting provider.
Note: The “root” folder may be different from one server to another. Often the location of the root folder is ““
(nothing) or simply “/”, but these locations don’t always point to the “home” folder. Check with your web hosting
provider to determine an appropriate value to use here if you are still unsure.

16) Proxy. This option lets you configure your proxy settings if your hosting provider requires that you
use a proxy. If you aren’t sure whether you use a proxy, you probably don’t. Click the Edit button to
open the Proxy Settings window. Here, you can create a new proxy or edit or delete an existing one.
• To add a new proxy, click New, enter the proxy name, proxy URL, username, password, and
proxy port in the provided fields, and then click Add.
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• To modify an existing proxy, select it from the list on the left, make the necessary changes, and
then click Update.
• To delete an existing proxy, select it from the list and click Remove.
17) Comments. Enter any comments about the server in this field.
18) Modification Time. When you transfer a file, the timestamp of when the file was last modified will
be changed. You can choose to preserve the previous modification time for downloads and/or uploads
by checking the appropriate box; however, transfer speeds may be slowed by this.

Step 2: Connecting to Your Server
Once you have set up a server profile, you can simply click Connect. Alternately, you can click the arrow next to the Servers button on the Toolbar and select the desired server from the list.

You can tell you are connected when the Remote pane on the right-hand side of the program is populated with files and/or when the Disconnect button on the Toolbar appears in color.
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Step 3: Navigating Your Computer and Server
The last step before uploading your files is moving to the location on your computer containing the
files you want to upload, and to the location on your server where you want to upload those files to.
The process is the same for both areas. To enter a folder, double-click it. To access your recently visited places using the drop-down list at the top of the Local and Remote panes. You can also move up
one folder, double-click the folder icon with two dots (..) at the top of either the panes.

Step 4: Uploading Files to Your Server
Once you’ve opened the local folder containing the files you want to upload and the folder on your
server where you want to upload them, select the file or folder you want to upload from the Local pane
on the left-hand side of the program. Next just click the Upload button in the toolbar. Alternately, you
can use your mouse to drag the file over to the Remote pane on the right-hand side of the program.
Note: If a folder is selected in the Remote pane, files will be uploaded to that folder rather than the one that is
displayed—but you won’t see the uploaded files until you navigate to the selected folder!
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To see the transfer activity, hit Ctrl-T to open the Transfer Activity window.

The leftmost pane displays a list of transfers or error messages: An up arrow indicates an upload
while a down arrow indicates a download. The rightmost pane displays detailed information about a
selected transfer.
When a file is done transferring, it will remain in the transfer list until you remove it by selecting the
transfer and clicking the red X button. Now you can view the file on your server. You can also pause
and resume transfers using the Pause and Play buttons to the right of the X. There is also a preference
to automically delete successful transfers which can be set by going to Edit > Preferences and checking
the box next to Remove completed transfers from the Activity list.

Step 5: Downloading Files From Your Server
Downloading files from your server is basically the same as uploading. First, select the file(s) you wish
to download from the Remote pane. Next, click the Download button on the toolbar or just drag the
files to the Local pane. You can also select a folder or drag and drop files onto a folder to select it as
the destination.
The file and transfer will appear in the Activity list just as the files you uploaded did. The only difference is that the arrow icon under Status is pointing down.
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Working With Bookmarks
Bookmarking folders you use often can help save a lot of time. These instructions will show you how to
create, edit, and delete local, remote, and combo bookmarks.

How to Create a Local or Remote Bookmark
1. Select the folder on your computer or your server that you wish to bookmark.
2. Click the Bookmark button on the toolbar and select Local or Remote Bookmark.
3. In the window that appears, enter a name for the bookmark.
You can now access this bookmark by going to Bookmarks > Local/Remote Bookmarks, depending on
whether you bookmarked a folder on your computer or your server.

How to Create a Combo Bookmark
A combo bookmark opens a folder on your computer and a folder on your server at the same time:
1. Open the folders you wish to bookmark in the Local and Remote panes.
2. Click the Bookmark button on the toolbar and select Combo Bookmark.
3. In the window that appears, enter a name for the bookmark.
4. You can now access this bookmark by going to Bookmarks > Combo Bookmarks.

Adding, Editing, or Deleting Bookmarks in the Manage Bookmarks Window
You can add, edit, or delete bookmarks by going to Bookmarks > Manage Bookmarks. This opens the
Manage Bookmarks window.

Here’s how to add a local or remote bookmark in this window:
1. Click the Add button.
2. Enter a nickname in the Nickname field.
3. Use the Browse button to browse your computer or server for the desired file path.
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And here’s how to add a combo bookmark:
1. First, set the local and remote bookmarks you wish to use in the combo bookmark.
2. Click the Add button.
3. Enter a nickname in the Nickname field.
4. Select the remote and local bookmarks from the provided drop-down list.
To edit bookmarks in the Manage Bookmarks window, just select them from the list on the left-hand
side and edit the provided fields as necessary. To delete a bookmark, select it and click Delete.
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Using the Editor
The following instructions will walk you through the process of opening and editing a file in the Editor
pane. Feel free to read through the entire tutorial, or skip ahead using the links below:
• Creating or opening a file
• Working with text
• Previewing
• Adding an image
• Saving changes
• Creating a link

Step 1: Creating or Opening a File
To create a new HTML file in the Editor pane, click the New Document icon in the Editor Toolbar.

A window will open prompting you to enter a name for the file. Enter a name (be sure to use the correct file extension), click OK, and you’re ready to go! Opening a file is even easier: Just drag it from the
Local or Remote pane into the Editor pane.

Step 2: Working With Text
The Editor is a full-featured webpage editor, so you can use it to write any website language you want
(e.g. HTML, CSS, JavaScript, PHP, ASP, etc.). It also gives you tools to perform basic HTML changes
quickly. The toolbar contains icons that let you bold, italicize, underline, and align text, insert paragraph tags, and change the font.
For this example, let’s add a paragraph of text. Say we’re editing a page that contains a message
thanking the user for completing a short survey.
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Now, say we wanted to add a note to this page stating that each e-mail address is only entered in the
draw once. You could type the HTML yourself, or you could use the tools in the Editor toolbar to help
you out. First, we’ll type out our message, and then we’ll apply some styles to it. First, highlight the
entire paragraph, and then click the Paragraph icon in the Editor toolbar.

This automatically adds the HTML paragraph tags to the document. Next, let’s make the word “Note”
stand out by bolding it. Highlight “Note” and then click the Bold icon in the Editor toolbar.

As with the Paragraph icon, this adds the necessary HTML for you.

Step 3: Previewing
Let’s check out how our changes look! To do this, click the Preview webpage icon in the Editor toolbar.

This opens the file in a web browser:
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That looks pretty good, but maybe we should spice this page up a little with an image.

Step 4: Adding an Image
Just like when you’re making text changes, you can add the image HTML manually, or you can use the
tools provided in the Editor toolbar. To do so, first click the location on the page where you’d like the
image to appear, and then click, the Add Image icon.

This opens the Image Information window.

Here’s what to enter in the provided fields:
• Image name: The filename for the image you wish to use.
• Brief description of the image: The alt text for the image. Alt text is displayed when an image
cannot be displayed, such as in a text-only or speech browser, or if a user has a slow connection. You should always use detailed alt text for all contextually important or prominent images
on your webpage.
• Image border: The desired border for the image, measured in pixels. Enter 0 if you do not wish
to use a border. The maximum border size is 100 pixels.
• Alignment: The alignment for the image. Your options are left, right, top, middle, and bottom.
Once you’re done entering the required information, click OK, and the HTML will automatically be
added to your file.
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Step 5: Saving Changes
We’ve made so many great changes to our file that we should definitely save it. There are a couple of
different options to do this. First, decide whether you want to save your file to your computer or your
server. If you want to save your file to your computer, click the Save button in the Editor toolbar and
select Save Local.

If you’d rather save your file straight to your server, select Save remote – Original folder or Save
Remote – Current folder. The Original folder option saves the file to the folder where it was originally
stored on the server, and the Current folder option saves it to the file currently open in the Remote
pane.
Note that the Original folder option will only appear if this file previously existed on the server; if it did, the
Current folder option will only appear if it differs from the original folder.

Step 6: Creating a Link
Let’s give our users a way to get back to our homepage from this page. As with the other options we’ve
covered so far, you can add the HTML yourself, or you can use the tools provided in the Editor toolbar.
To do so, first click the location on the page where you’d like the link to appear, and then click the Add
Link icon.

This opens the Link Information window.

Enter the following information in the following fields:
• Website Address: The URL where the link points to.
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• Link Text: The text that appears as a link.

Once you’re done entering the required information, click OK, and the HTML will automatically be
added to your file.
Using the method described in Step 3, you can preview your page one last time. If you like what you
see, you can either save it to the server or save it to the computer and upload it normally.
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Using the Image Pane
Using Direct FTP’s Image pane, you can open an image to preview it, edit the associated HTML, add
the image to a webpage, and even edit it (if you have Web Image Studio). You’ll need to choose View >
FTP and Edit View to use this pane.

Here’s how to preview and edit the HTML of an image:
1. Right click the image you’d like to preview/edit from either your computer or your server and
choose Preview Image.
2. Enter the alt text for the image in the Alt text field. Alt text is displayed when an image cannot
be displayed, such as in a text-only or speech browser, or if a user has a slow connection. You
should always use detailed alt text for all contextually important or prominent images on your
webpage.
3. Enter the desired border size in the Border field. Enter 0 if you do not wish to use a border. The
maximum border size is 100 pixels.
4. Choose the desired alignment from the Alignment drop-down list. Your options are left, right,
middle, top, or bottom.
5. To insert the HTML for the image into the currently open document in the Editor, click the Insert Image button. This automatically opens the Editor pane so you can move the image HTML
to the desired location in the document. If you do not have a document open in the Editor, this
button is disabled.
Note: Direct FTP will do its best to determine the relative path of your image on the server; if the image is not
visible, you may need to enter the path of the image manually.

Editing Your Image in the Image Pane
The Image pane features four icons in the upper left corner. They are, from left to right:
• Edit in Web Image Studio
• Save Web Image Studio changes
• Undo Web Image Studio changes
• Close current image
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Using these buttons, you can edit any image you are previewing.

You’ll need the latest version of Web Image Studio to be able to use these options. If you already own
it, you can download your free update or you can purchase Web Image Studio from the CoffeeCup
website.
If you have an image open in the Image pane, click the Edit in Web Image Studio button. Your image
will now be opened in this cool image editor, where you can make just about any change you can think
up. Consult Web Image Studio’s help documentation if you need further guidance.

To return your edited image to Direct FTP, simply click the Save toolbar button. This displays your edited image in Direct FTP’s Image pane. You can now save your image by clicking the Save Web Image
Studio changes button or revert to the original image by clicking the Undo Web Image Studio changes
button.
To close an image, click the red X button or right click its tab and choose the right option.
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Direct FTP Preferences
To get the best experience possible from Direct FTP, you may want to customize the program’s preferences. To do so, go to Edit > Preferences. This section will help you determine which settings to
configure.
Note: The Proxy tab is typically for advanced users; if you’re not sure what a proxy is or how to configure it, you
probably don’t need to use it. :)

General
This is where you can configure many of the settings related to the way that the program itself works.

Double Clicking
There is a drop-down for setting both local and remote file double-click behaviors. This refers to files
shown in the local and remote panes in the main window and what occurs when those files are doubleclicked.

File Date Format
This is how the date is shown in file lists within Direct FTP, and has no effect on the dates themselves
nor time zone correction.
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Web Browser Used for Previews
You can choose whether you’d like to use the default browser or a separate browser to preview web
documents. To choose another browser, locate the program on your hard disk with the Browse button.

Remove completed transfers from Activity list
Removing data frees memory and reduces the burden on your CPU. This option is recommended for
users who don’t have high-powered machines.

Terminal Program
You can specify a terminal program to use if you need to connect to a server via SSH and use a command prompt. Most likely, you won’t need to do so.

FTP
This section allows you to configure the way that the FTP connection itself is handled.

Upload to temporary file…
In a default FTP connection, files are simply overwritten if the pre-existing file has the same filename
as the one being uploaded. If the transfer fails halfway through, this may leave you without a working
copy of the file! Instead, you can choose to upload using a temporary filename which is changed to
overwrite the pre-existing file only when the transfer is successfully completed.
There are, of course, reasons to choose not to use this option: Resuming an upload will not work with
this option, transfer rates may be slower (especially with lots of small files), and the server may end
up with temporary files if the connection is broken unexpectedly.
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Write transaction log to…
This option will create a plain text document that lists uploaded/downloaded files and records their
failed or successful transfer.

Detect FTP Passive mode automatically
If you don’t understand Passive mode, it is safe to use this option; however, it’s still better to ensure
that the correct server settings are used if you are able to configure them.

Server Confirmations
For each server that you use, you can set the confirmation behavior. To do so, click the green + icon
and choose a server; now select one of the behaviors listed below.

Editor
In this section, you can configure settings for Direct FTP’s in-program file editor. There are 4 tabs here
with many different options.

Display
The 12 options here configure how code is displayed in the code editor.
• Show white space guide: Places a small dot where spaces have been used in the guide.
• Syntax highlighting: Highlights elements in code to help visualize the different components.
• Display EOL: Means “End of Line”; Shows where the enter key has been pressed.
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• Show line numbers: Displays numbers for each line of code in the left margin.

• Display indent guide: Helps you visualize indentation (where the Tab key has been pressed).
• Show visible right margin: Displays a margin on the right side of the code.
• Folding enable: Allows you to close blocks of code to temporarily remove them from view.
• Read only: Locks a file so that it cannot be edited.
• Word wrap on: Wraps lines of code instead of extending them into the right margin.
• Auto-indent: Helps you keep your code clean by anticipating indentation.
• Overwrite: Characters you type are written directly over ones that exist where the cursor is.
• Drag-and-drop-enabled: Allows you to highlight, drag, and place code in the editor.

Colors
Configure the color scheme of your code editor. Choose the programming language you would like to
edit from the drop-down menu, and then select elements from the leftmost pane. You can apply text
attributes (bold, italic, and underlined) to that element, and select a foreground and background color
from the two panes on the right.
Cuztomizing your own color scheme is not necessary, but if you don’t like the way the code is colored
by default, it’s great to have the option to change it.

Files
This tab allows you to configure how specific file extensions are handled. For this reason, if you open a
file that has an extension that isn’t defined yet, you’ll be directed to this tab. Simply configure the file
extension according to its appropriate file type.

Auto-Completion
The auto-completion options help you code faster, easier, and generally more efficient than ever before. There are 5 options in this tab.
Auto-completion enabled: Known elements in code are anticipated as you begin to type them. This
saves you from accidentally misspelling code.
Add double quotes to HTML parameters: Most browsers will validate HTML without the use of double
quotes, but some won’t. Selecting this option will add them for you automatically.
Wrap selection in quotes with hitting ‘ or “ key: Highlight a block of code and press either the single
quote or double quote key to place quotes on both sides of the selected code.
Close HTML and XML tags automatically: You may not always remember to close a tag, especially when
the content inside of it is long. This option prevents you from leaving the closing tags out.
Edit Opening and Closing tags simultaneously: When you make a change to one tag, it still needs to
match the other one. In other words, there’s no reason to edit one and not the other. Selecting this option saves you from needing to type the same tag name twice.
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Security
This section is essentially for configuring the way passwords are handled by Direct FTP.

Encryption Password
If this setting is used, your password will be heavily encrypted, and server credentials will be unreadable if the correct password is not entered. Encrypting the password is helpful because it makes it
unlikely that someone will be able to discover your password if they steal your Shared Settings file.
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Frequently Asked Questions
Features, Tools, and Functionality
What Are the Limitations of the Trial Version of Direct FTP?
The trial version of Direct FTP has the same functionality as the registered version. The only difference
between the two is that the trial expires after 7 days of use.

Can I Transfer My Profiles to Another Computer?
Sure can! Here’s how:
1. If you are using Windows XP, go to C:\Documents and Settings\Administrator\Application Data\
SharedSettings.ccs. If you are using Windows Vista or Windows 7, go to C:\Users\AppData\
Roaming\SharedSettings.ccs.
2. Right-click the Shared Settings file and select Copy.
If you don’t see the Shared Settings file, you may not have the option to view hidden files
turned on. To display hidden files in Windows XP, open any folder (e.g. My Documents) and
select Tools > Folder Options > View tab, and then select Show Hidden Files. To display hidden
files in Windows Vista or Windows 7, open any folder (e.g. Documents) and select Organize >
Folder and Search Options > View tab, and then select Show Hidden Files.
3. Paste the Shared Settings file into an external data storage device (thumb drive, external hard
drive, CD-ROM, etc.) by opening the data storage device, right-clicking the background, and
selecting Paste.

How Do I Back up my Site?
Making backups of your files is an important part of being a webmaster. After all, you never know
when you may need access a previous version of your website. Direct FTP makes it easy to back up
your site. First, navigate to the folder you want to back up. Next, click the Archive button on the toolbar. This will save the current folder’s contents to your computer as a ZIP file.

How Do I Change File Permissions? / How Do I CHMOD?
If you need to change the permissions of a file or folder on your server (a process also known as
CHMOD), you can use the handy tools in Direct FTP.
First, select the file or folder whose permissions you wish to change. Next, click the Permissions button on the Remote toolbar. This opens a window that allows you to change the permissions for the
selected file or folder.
The options are read (the group has permission to read the file), write (the group can modify the file),
and execute (if the file is an executable, the group can run the file). The three groups are Owner (you),
Group (the group of users you belong to), and Users (everyone else in the world).
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You will also notice the Hex field at the bottom of this window. This allows you to enter a numeric code
to change the permission of the file, and can be useful if you are given instructions to CHMOD a file.
For instance, if you are following instructions to add a guestbook on your server, and you are instructed use CHMOD 755 on a certain file, you would just have to enter 755 in the Hex field.

Error Messages and Troubleshooting
I Can’t Connect. What’s the Deal?
If you receive a specific error, refer to one of these articles:
• “425 can’t open data connection” error.
• “11001 in Request ConnectAsync 500 Host Not Found Winsock #11001” error
• “11004 in Request ConnectAsync 500 No Data Winsock #11004” error.
• “530 Login Incorrect” error.
• “426 Connection Closed; Transfer Aborted or 503 Bad Sequence of Commands” error.
If none of those articles help you, there are several possible causes for this issue.
Incorrect Login Information
First and foremost, double-check your FTP settings to ensure that they have been entered correctly. A
common error is preceding your server name with ftp:// or http://.
Incorrect Proxy Information
Make sure you did not enter proxy server information by mistake. If you don’t know what a proxy
server is, or if you have not been instructed to use one by your hosting provider, then you most likely
don’t have one. To check whether you have filled in proxy information, go to Edit > Preferences > Proxy
tab. If you have any information filled out in those fields, remove it and click OK. Now restart the program and try connecting.
Firewalls
If the issue isn’t corrected by removing proxy information and/or enabling passive mode, the culprit
may be your firewall software, such as Norton Personal Firewall and ZoneAlarm. What you’ll need to
do is add Direct FTP to the list of exceptions. For specific instructions, consult for the firewall software
you are using.
If All Else Fails...
You may want to try deleting the server profile in Direct FTP, and then recreating it. If you still cannot
connect, contact your hosting provider, or talk to one of our tech support gurus in your support room
(http://www.coffeecup.com/help/).

“425 Can’t Open Data Connection” Error.
You’ll usually get this error if you don’t have passive mode turned on. To do this, go to File > Manage
Servers and select Passive mode. If you have already disabled passive mode after receiving a “426
Connection Closed” error, try disabling any local firewalls before connecting.

“426 Connection Closed; Transfer Aborted or 503 Bad Sequence of Commands” Error.
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Some servers do not allow passive transfers and will return this error if you try using passive mode.
Try disabling passive mode by going to File > Manage Servers and unchecking Passive mode. If after
doing that you receive a 425 error, try disabling any local firewalls before connecting.

“530 Login Incorrect” Error.
This error is caused by an invalid username or password. If this connection has worked in the past,
you may try deleting the profile and creating it again. Also, check to make sure there are no spaces
before or after the username and password. You should also verify the information with your web hosting provider to make sure it’s correct.

11001 in Request ConnectAsync 500 Host Not Found Winsock #11001
1. Make sure you are connected to the Internet.
2. Make sure the server you are trying to connect to is spelled correctly.
3. If your Website is fairly new, the DNS may have not propagated yet, and the server you are
using may not have an IP associated with it. To test this, go to Start > Run, type in CMD and
press Enter, and type in PING yourdomainname.com. If it says “Ping request could not find
host” or “Host not found,” the domain name you are trying to connect to isn’t working correctly.
At that point, contact your web hosting company. They may be able to provide you with your
actual IP address to use until the DNS has propagated.

“11004 in Request ConnectAsync 500 No Data Winsock #11004” Error.
This error can occur if you put something invalid in the Server field. For example, you should not precede your server name with anything like http:// or ftp://.

When I Close the Program, it Appears to Stay Connected to the Server and Does not Present
an Option to Disconnect.
Not to worry — when Direct FTP closes, it also automatically closes any open connections. If the program appears to be connected on startup, this may be because you have set the program to restore the
last connection on startup. To change these options, go to Edit > Preferences > FTP tab.

I Can’t Delete Certain Files or Folders.
If, when trying to delete certain files or folders, the icon just flashes, disconnect and then reconnect to
your server and try again. If this doesn’t work, you may want to contact your Web hosting provider to
check the ownership/permissions of the files/folders you are trying to delete.
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Miscellaneous
I Accidentally Deleted File(s) and/or Folder(s). Can I Recover Them?
If the deleted files were local, just check the Windows Recycle Bin. If you haven’t emptied it recently,
you can recover your files there.
Unfortunately, there is no way for an FTP client to recover accidentally deleted remote files. However,
if your web hosting provider has a backup of your site, this may be possible. Contact them to find out.
If you would like to create a ZIP archive of your important files or folders, just select the files you wish
to protect and click the Archive button in the toolbar. This saves a copy of your files to a different location of your choice.

I Found a Bug. What Do I Have to Do to Report It to the CoffeeCup Team?
Direct FTP has a built-in log system that logs all the actions performed within the program. To use the
log system, first close Direct FTP, then hold down the Shift key and double-click the Direct FTP desktop
shortcut. This opens a window that displays the location of the log file and asks if you would like the
log to be verbose. Be sure to note the location of the log file and then click Yes. Next, send a copy of
the verbose log file to our tech support team at http://www.coffeecup.com/help/.
Because the log can slow down your computer, it is not automatically enabled. Instead, it’s available
when you choose to enable it.
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Keyboard Shortcuts
You can perform the most commonly used functions in Direct FTP using keyboard shortcuts. Below is a
complete list of all the keyboard shortcuts available in the program:
• Save as Local File – Ctrl+S
• Save to Website – Ctrl+Alt+S
• Print – Ctrl+P
• Exit Direct FTP – Ctrl+Q
• Undo – Ctrl+Z
• Redo – Ctrl+Y
• Cut – Ctrl+X
• Copy – Ctrl+C
• Paste – Ctrl+V
• Select All – Ctrl+A
• Delete – Del
• Find – Ctrl+F
• Replace – Ctrl+H
• Open Transfer Window (When not in Editor) – Ctrl+T
• Open Image Information Window (In Editor only) – Ctrl+T
• Insert Snippet – Ctrl+J
• Upload to Server – Ctrl+U
• Download From Server – Ctrl+D
• Rename – F2
• Edit Selected File(s) – Ctrl+E
• Refresh – F5
• Help – F1
• Online Help – Shift+F1
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Contact Us
We give you more then just software. We have a mission when it comes to support: Be extraordinary!
When you buy our software, what you get goes well beyond what you expect from a software company.
We do not offer tech support — we offer coaches and counselors to help you with the software and web
design. We are here for you so you can be a successful webmaster, not just learn a piece of software.

Registered customers always get:
• The software you paid for, of course.
• Free e-mail support (ask a question, get an answer within 24 hours.)
• Free upgrades for life and access to download software at any time.
• Access to our user forums (http://www.coffeecup.com/forums/) where you can talk about web
design or share business tips.
• Exclusive discounts and sneak peeks at new software or services.

Trial Support Services:
We are always happy to help you with your questions about our software. If you are using a trial version of
our software you can use the online Knowledgebase (http://www.coffeecup.com/help/) or e-mail our support
staff any time. Feel free to ask us your questions, and we will reply as soon as possible.
Get priority support and access to our Support Center (https://www.coffeecup.com/help/) when you
order our software. Our mission is to provide the best possible service to our customers. Join the ranks
of webmasters worldwide and order our software today. You’ll be happy you did. :)

Our Address:
CoffeeCup Software
165 Courtland Street
Suite A, Box 312
Atlanta, GA 30303
USA
Phone: (678) 495-3480
http://www.coffeecup.com/

Thank You!
To all our users — you know who you are…
Without the support and feedback of those who download and buy our software, we wouldn’t be here.
We are very lucky to have had so many people over the years think our software is great, and we are
proud that you still do. Thank you, everyone!

Still Can’t Find Your Answer?
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Visit our user forums (http://www.coffeecup.com/forums/), check out the articles and video tutorials
in our online Knowledge Base (http://www.coffeecup.com/direct-ftp/help/), or contact our fabulous
tech support team! (http://www.coffeecup.com/help/)

